Permalink

0

PHP 5.3.10 and APC 3.1.9 on Ubuntu 10.04.4

This is not the latest Ubuntu LTS or PHP versions but it happens to be my current configuration until Xen is working better with 12.04 (hopefully 12.04.1) and I’m also waiting for a stable Suhosin patch for PHP 5.4 on 12.04 (also, hopefully 12.04.1).

To get PHP 5.3.10 on Ubuntu 10.04.4 LTS I recommend using Brian Mercers PPA. It is not being updated any longer but that’s fine since I’m only concerned with having PHP 5.3.10 with Suhosin.

Either type:

sudo apt-add-repository ppa:brianmercer/php5

Or add this to your /etc/apt/sources.list file:

deb http://ppa.launchpad.net/brianmercer/php5/ubuntu lucid main

In my case I use PHP-FPM so I installed it like so:

sudo apt-get update
sudo apt-get install php5-fpm

To avoid getting this error when installing APC…

/usr/include/php5/ext/pcre/php_pcre.h:29:18: error: pcre.h: No such file or directory

You will need this pcre package

sudo apt-get install libpcre3-dev

Then install APC using pecl:

sudo pecl install apc

Author: Matt Drollette

I am a software developer in Dallas, TX.

Leave a Reply

Required fields are marked *.